A different post code

Prior to this weekend, it had been driven about 20 miles by my dad, and I was able to get down for a day, and in that time we have found, and had to sort the following teething issues:

Replace injectors – I fitted new filters to them, but in doing so, managed to get some dirt into some of them, which left them stuck open, pouring fuel into the engine!

Tweak the ECUs – the MAP-ECU appeared to lose some of its configuration, meaning that it was not actually giving a signal to the standard engine ECU for air flow! So the first 5 miles or so, it was running only on the “fail safe” fueling!

Replaced all the spark plugs, as it was missing under load.

Discovered that the tyres on the back are awful, as under power, it was pulling quite hard to the left, and to the right under deceleration. Swapping the rear tyres side to side improved it, so a new pair of tyres had been ordered and been fitted.

The PLX wideband O2 sensor control unit has failed, so it’s not putting out the correct voltages on either the wideband output, nor the simulated narrowband output. This has been removed, and replaced with the stock narrowband sensor until I can afford a new wideband controller.

With the annual “Anglias At The Ace” happening the weekend just gone, and determined to get there, I went down and spent last Thursday night and Friday doing some more to make it ready. My dad had done some more filling & sanding, getting the car ready for paint. However, with life getting in the way, by Thursday it was only nearly ready for priming – so Thursday evening was spent finishing off the sanding back, and giving it a blow over with primer – which was finished at 12:15 on Friday morning!


Friday morning I got up early, and spent the morning undersealing the car – if we were taking it on the road, the bits we’d previously welded and primed needed some better protection. So, after masking up all the bits I didn’t want to get covered in underseal:

Undersealing Undersealing

I covered both myself and the underneath of the car with underseal:

Undersealing Undersealing

During the small amount of driving it had done, we noticed that the bonnet got VERY hot right above the turbos – so something was needed to reduce the heat transfer into the fibreglass. With a sheet of nice thick stainless steel, I made up some heat shields to cover the turbos, bolted onto the strut tops, so that the heat is transferred into the rest of the body.

Turbo heatshields Turbo heatshields

With all that done, and just 25 miles on the odometer, it was time to firstly give the interior a good hoover out as it was covered in filler dust, and then take it out for a bit of a longer drive – firstly to see if the new tyres made a difference to the handling, secondly to see if the heatshields had made a difference before the “long” drive to the Ace Cafe, as well as to shake down anything else that we’d not picked up yet.

Given that I’d only driven it about a mile so far, I went out onto the road tentatively, and all felt good. As I started to become a little more confident, and the engine came up to temperature, I pushed it a little harder, until I was trying out some full-throttle runs. However, here is where I found an issue – it pulled great in 1st and 2nd all the way to the red line (no pulling to the left now the new tyres are on), but in 3rd and 4th, it got to just over 4000rpm and hit a rev limiter.

Came back, and got the laptop out and hooked it up to the ECUs to check the configuration. Nothing jumped out at me, so went out for another drive to save some log files for looking at later. There was also a small “chirping” coming from the back, which was related to road speed, that disappeared when lifting the handbrake slightly. Got it back home with the odometer now on a huge 49 miles!

I did find when looking through the logs that the original Mitsubishi ECU thought that I was doing over 400km/h – I certainly wasn’t doing that!! I then remembered that the speed limiter on the ECU can’t be removed, but it can be increased to 255 MPH – which is 410km/h!

So, with it being late on Friday, on Saturday morning got out early, cut the speed sensor signal to the ECU, and removed the rear wheels to back off the handbrake slightly.

With that done and back on the ground, we set off for our drive to the Ace. As this was the furthest from my dad’s post code it has yet to be driven, we decided it safe for my dad to follow me in his Shogun with a trailer and a boot full of tools – just in case anything was to go wrong or not feel right, we could simply load it up, and deal with it later.

Heading off down the road, first I noticed that there was no more chirping from the back end. Getting onto the dual carriageway, I gave it full throttle in 3rd, and it revved straight past 4000rpm and to the redline – so it obviously was the engine ECU engaging the speed limiter at 4000rpm.

I had to pull over about half an hour and 25 miles after leaving home, however. As dad pulled over behind me, he gets out the Shogun with a worried look on his face as I walk towards him. “Can I have the duct tape, please?” I ask. “The chrome surrounds for the heater controls, and the ashtray are rattling, and it’s annoying me”, I add.

After taping up the rattling trim, the rest of the journey to the Ace was completely uneventful.

ace1 ace2

Another great day, met and chatted to plenty of lovely people, and saw 49 other lovely Anglias!

Then I drove it back home without any more issues, pulling up back at my dads with 210 miles on the clock. On a run, the engine coolant temperature gets a little higher than I’d like it to be, so (as was always expected) a better radiator is required for more serious running – but it’ll sit happily at 70mph without overheating as it currently is.

It’s only running at about 6psi of boost at the moment (I’m hoping I can get around 14psi out of it), so it’s not quite as quick as it could be, but… even with that, it’s rather quick! Using the timers built into the gauges, and still not *really* pushing it too hard yet, it’s given so far a <7 second 0-60, and under 17s quarter mile. Just need to get it tuned right, get the launch control set up, and get it to a drag strip to see what it can really do! IMG_6031 IMG_6036